Technical Information

System Requirements

In order to ensure that the NASD OTC Markets Website is rendered with all necessary plug-in and helper technologies, you need to meet the following minimum requirements


A dedicated broadband internet solution works best


Supported browsers technologies
Internet Explorer 7.0+
Firefox 3.0+
Epic 1.9+
Safari 5+
Opera 8+
Netscape Navigator 8+


Browser settings
Java applets and JavaScript must be enabled in your browser. The NASD OTC Markets Website is based on WEB 2.0 functionality such as Ajax (asynchronous HTTP requests). Please ensure that JavaScript and Popup capabilities are not blocked in your Internet service (e.g. LAN firewalls or browser settings). Contact us by filling out our contact form should you have any questions.


What Plug-ins are supported?
Java 1.6.x plug-in (freely available)
Adobe Flash 8+


Tracking technologies ("cookies")
The NASD OTC Markets Website installs "cookies" on your system. A cookie is a small text file that our Web server sends to your Internet browser and is saved on your computer. As a result, we are able to recognise you upon your next visit to our website.


Will there be any changes to technical details?
The NASD OTC Markets reserves the right to modify or update the technical information above. We recommend you visit our site regularly for any updates or changes.

Quick Links

Office Location NASD Help Desk Careers Whistle Blowing Who We Are Registration FAQs

Market News

  • 02Mar, 2018
    Where is NASD in the ERGP?
    Read More
  • 17Jan, 2018
    Coronation Securities Limited, Apel Assets Limited lead Participation on the ...
    Read More
  • 05Jan, 2018
    Mass Telecom Innovation Plc. (MTI) Now Trading on the OTC ...
    Read More